Articles, Blog

How install Lightroom 4 or 5 on Linux (Wine 1.7) Mint 17, Ubuntu etc.

September 8, 2019


If You have older wine version than 1.7 – uninstall it. Add ppa repository for latest wine version Run Your favourite package manager to install Wine 1.7 ie. SYNAPTIC Check Wine 1.7 or newer and winetricks. After instalation check wine version run “winetricks” from console and install packages Run Lightroom 4 or 5 installation. Now the files are unpacked When done, run setup32.exe. 64bit version not working. If You get message about “…that Your computer is running Windows Vista or later”, You need change wine configuration from Windows XP to Windows Vista or later. After instalation run LR from desktop icon. If everything went well, Ligtroom will start.

12 Comments

  • Reply Maciej Chyra July 8, 2014 at 9:15 am

    Abhijeet, i've made english subtitles.

  • Reply kamaboko1 July 15, 2014 at 2:21 am

    Could not get it to work with Mint 17 KDE.

  • Reply Hans Petter Birkeland September 30, 2014 at 7:03 pm

    Hi,
    I tried this on a fresh install of Mint 17 64 bit, exactly as you do in the video, but with Wine 1.7.27 and Lightroom 5.3. The installation of the 32 bit Lightroom starts, but then it stops with an error after a while, at "Status: Registering modules". Any idea why?

  • Reply heyJustephan January 26, 2015 at 11:05 pm

    Awesome, Polish guy for president.

  • Reply Martin Bachmann February 7, 2015 at 11:07 am

    Works great on Ubuntu 14.10 64bit. Thanks!

  • Reply poeli1 August 2, 2015 at 6:59 pm

    what about work-performance? is it okay?

  • Reply PixelMotionHD August 23, 2015 at 11:55 am

    Masz pomysł, dlaczego wersja 64 bit nie śmiga pomimo faktu instalacji linuxa na 64 bit? Mam minta 17.2

  • Reply Алексей Литвинчук October 2, 2015 at 8:39 pm

    installed. when trying to open – fault "can't create a folder" (Linux mint with kde desktop, wine 1.7.50) Tryed lightroom 4.4 and 5.7.1

  • Reply roc97007 December 17, 2015 at 7:49 pm

    I have Mint 17 on a laptop, will try this. I also have Adobe CS4, would be interesting to try that also.

    I've said for years that if the Adobe CS suite worked on Linux, I'd walk away from Windows and never look back. Maybe now is the time.

  • Reply Vova Shpigalo April 1, 2016 at 10:32 am

    Hello i have this Wine
     Error: the program lightroom.exe has encountered a serious
    problem and need to close. we are sorry for the
    inconvenience.
    Pleaes help me.

  • Reply Gvarnerian May 20, 2016 at 3:31 pm

    Hello!
    I did everything you said, but lightrom but it hangs when booting. What you can try. Me too Mint 17.3 Wine 1.7.55 and lightroom 5.7.1

  • Reply Sumit Kasara September 29, 2017 at 2:09 pm

    what to do after step – 3 , i can't understand well!!!

  • Leave a Reply